Can I have some pages automatically open on the web instead of 404-ing in the archive?

I am trying to embed an archive of a subdomain. I’d like any links that are off of that subdomain to open on the web. Instead, links that aren’t in the archive always get the 404 page with the instructions for how to try the url on the web. Is there a way to bypass the 404 page and just go out to the web? Perhaps a way to tell the proxy only to try to proxy pages on a certain domain? Am I just missing an embed parameter?

Yes, there is actually an undocumented advanced option to do this:

<replay-web-page ... config='{"liveRedirectOnNotFound": true}'>

I think it wasn’t fully tested, but could definitely make it a more clearer <replay-web-page liveRedirectOnNotFound>

Let us know if this works for you.

Note that it will redirect the entire page, not just the embed, because there’s no guarantee that the page could be loaded in an iframe otherwise. Are you looking to load the live page in place of the embed?

There is also additional, experimental replay work for replacing an entire domain/subdomain with replay. Depending on your use case, that may be of interest as well.

I tried the below, but it didn’t work (still getting the 404 message). I’m using

      embed="replayonly" config='{"liveRedirectOnNotFound": true}'></replay-web-page>  

I also tried:

   <replay-web-page ... liveRedirectOnNotFound></replay-web-page>  


   <replay-web-page ... liveRedirectOnNotFound="true"></replay-web-page>  

Reloading the entire page is ideal. Our use case is archiving an old brochure site that was done in a drag-and-drop CMS. We’ve tried using Httrack and a few other tools, with limited success. Some of the links in that page go to our main site.

The config settings are refreshed only on full reload, try opening in incognito window or doing a ‘Purge Cache + Reload’ with the config='{"liveRedirectOnNotFound": true}' set.

That did the trick! I thought I was completely clearing it, but clearly was wrong. Thanks so much!