Seemingly simple webpage capture fails to load

I’m working with a team to archive materials relating to the Maui wildfires. Since I’ve used the tools like Browsertrix and before, I’m in the position of helping other volunteers.
I wonder if there are steps I can use to help guide through failed webpage captures. For example, a seemingly simple page like this is failing to load completely and ends up giving a 404 error.
Is there something obvious I’m doing wrong in initial capture, or that I can advise others on to get a more successful capture in the future?


Hi @alphie thanks for asking this question here!

Can you describe what fails when you try to view this archive that you provided? The pages seemed to display fine initially, but I noticed when I played it back that some of the dynamic menus display “loading messages” when you hover over them. I think that’s because the user didn’t hover over them during the archiving process?

Hi @edsu, yes, this was the issue I was getting with the loading. During the capture step, I didn’t see that message, or it loaded so briefly that I didn’t spot it, so it was surprising to see it in stuck like that in the recorded page, monopolizing the screen. I’ve tried recording pages elsewhere on the website, and the loading message consistently displays everywhere, but not on the live page. I tried hovering over as many elements as I could and I can’t seem to get the loading message to disappear.
This doesn’t seem to be a crazy sophisticated website so it’s just odd to me that this error is coming up.
Thanks for looking into it.

I tried archiving the page myself, and I see a constant Loading icon when I replay in ArchiveWebPage

But I exported the WACZ and can view that fine in ReplayWebPage:

I noticed this error in the console when viewing in ArchiveWebPage:

Couldn't load Ruffle into IFRAME[data:text/html;...] SecurityError: Blocked a frame with origin "" from accessing a cross-origin frame.

I created a GitHub issue to track this, as it seems like it highlights a difference between ReplayWebPage and ArchiveWebPage? WACZ plays back in ReplayWebPage but not ArchiveWebPage · Issue #184 · webrecorder/ · GitHub

Thanks, @edsu! I didn’t even think to check ReplayWebPage. I’ll make sure I add that to my steps for next time.

1 Like

The good news is that if you are looking to make the WACZs available you will likely use ReplayWebPage web component for that, so it should hopefully work!