Trying to access wacz on Dropbox

I’ve been unsuccessfully trying to access a wacz file on dropbox. I’ve substituted the with which supposedly bypasses a CORS problem. Here’s the link:

When I run it in a browser it successfully downloads the file. (This is a small test wacz as a proof of concept before I start playing with 36G wacz files).
When I run it in it errors out:

Interestingly enough it works fine on on macOS. (Maybe the CORS problem isn’t resolved with that alternate URL? Thoughts?

I’ve been using Safari on macOS Sonoma 14.2.1. I just tried Firefox and Chrome (both on macOS) and they access the file just fine.

Sounds like a classic case of CORS errors! I don’t believe Dropbox allows users to use it to host embedded web content in this way. I know you’ve already solved this in your other thread with S3, but figured I’d confirm here anyways. For future reference, check out the Configuring CORS section of our docs.

This is expected. CORS applies to websites with domains and when the app is running locally it isn’t either of those :slight_smile:

Actually, I finally got it to work from Dropbox with on the web in Firefox and Chrome… got this answer from the Github site: Configuring Server CORS | ReplayWeb.Page

1 Like

Neato! What did you need to change in Dropbox?

I sent you a reply in DM.

1 Like